Locked Payment Methods for WooCommerce

Lock certain payment methods from being used publicly and allow only pre-approved customers to pay for orders using them. Integrates with 3rd-party plugins like WC Memberships and Groups to grant access to a whole group of people at once.

Fully configurable

Turn unlocking strategies on or off at any point.

Configure each strategy separately on the appropriate screen.

Use WP filters to build in any additional conditional logic.

Multiple unlocking strategies

Grant payment method access to a user for all future orders.

Grant payment method access for a single unpaid order.

Grant payment method access to all users of given roles.

Grant payment method access to all users that have an active membership (WC Memberships) or belong to a group (Groups).

Fully configurable

Turn unlocking strategies on or off at any point.

Configure each strategy separately on the appropriate screen.

Use WP filters to build in any additional conditional logic.

Pricing

Annual licenses renew automatically unless cancelled beforehand. Lifetime licenses are a one-time payment. All prices exclude VAT, where applicable.

Secure payments by Freemius - Sell and market freemium and premium WordPress plugins & themes
All plans have a 14-days Double Guarantee refund policy.

You are fully protected by our 100% No-Risk Double Guarantee. If you don't like our plugin over the next 14 days, we'll happily refund 100% of your money. No questions asked.

Frequently Asked Questions

  • Do you offer a free trial?

    No, but we do offer a 14 days money-back guarantee. If any of our plugins doesn't fit your needs, we'll cancel your subscription and refund you the money if you reach out within that timeframe.

  • What happens if I cancel my subscription?

    You will continue to receive premium support and updates until the anniversary of your subscription. Afterwards, the plugin will continue working, but you won't receive anymore support or updates.

  • Will this plugin work with my theme?

    Normally yes. Any theme that follows the WordPress/WooCommerce coding standards should be compatible with all of our plugins. If you face any issues though, reach out to us and we'll fix it.

  • I have other questions

    Please reach out using our pre-sales support form on our contact page. We're happy to answer any other questions you may have!

Minimum Requirements

PHP: 7.4+

WordPress: 5.5+

WooCommerce: 4.5+

Current Version

Version: 1.0.0

Last Updated: 2021-04-15

Changelog: View